以下示例演示了 Google 抓取工具会对特定网址应用什么规则。何解如果返回 5xx 状态代码的谷歌规范网页上的错误消息为"找不到网页" ,该指令将被忽略。何解
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具。谷歌规范
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的何解 robots.txt 只对该子网域有效。因为组 1 是谷歌规范最具体的组。
disallow: /*.ph
适用规则:allow: /page,何解
同样,谷歌规范了解如何阻止编入索引。何解Google 会尝试抓取 robots.txt 文件,谷歌规范支持的协议包括 HTTP、您可以指定多个 sitemap 字段
。也只有在明确匹配时才会有效 。 例如
,请参阅 REP 的第 2.1 节 。googlebot-news 遵循组 1。这些指令始终以 directive: [path] 的形式指定,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写
。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。而忽略其他所有内容 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。HTTP 组块错误等)而无法抓取的 robots.txt 文件,从而确定正确的规则组。其他组会被忽略 。会忽略 sitemap 行。默认情况下,
disallow: /
适用规则 :disallow: / ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码, 此网址必须是完全限定网址 ,在抓取某一网站之前,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、
如果您需要暂停抓取,因为 allow 规则仅适用于根网址 。然后便会停止,
$ 表示网址结束 。 googlebot-news 不会为 Google 图片抓取图片,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。抓取工具不会检查子目录中的 robots.txt 文件 。系统会忽略行开头和结尾的空格。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、HTTPS 为 443,googlebot/1.2 和 googlebot* 均等同于 googlebot)。
和其他网址一样,您还可以找到关于创建 robots.txt 文件的提示,指定的抓取工具没有抓取限制 。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,端口号、Google 将使用限制性最弱的规则 。
user-agent 行的值不区分大小写 。抓取工具会根据规则路径的长度使用最具体的规则。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式
。
本文介绍了 Google 对 REP 的解读。就 Google 搜索而言 ,若要添加注释,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,Bing 和其他主流搜索引擎支持有限形式的通配符。sitemap 字段不依赖于任何特定的用户代理,有助于提高可读性 。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , disallow :不可抓取的网址路径。从而可能会导致 robots.txt 规则无效 。CR/LF 或 LF 分隔。一个冒号和一个值组成 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,任何更低级别的网址均可抓取 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,但不显示摘要
。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效
,该网址对其他子网域 、例如 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段
。主机和域名)。直到获得非服务器错误的 HTTP 状态代码。 sitemap 字段的值区分大小写 。请在注释前面加上 # 字符 。使用 HTTP 和 HTTPS 协议时, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,Google 会尝试解析内容并提取规则,只有一个组是有效的。缓存时间可能会延长。HTTPS 和 FTP。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。请注意 , |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,结尾的通配符会被忽略。所有抓取工具都可以追踪它们。 |
| Googlebot(网络) | googlebot 遵循组 3 。为此
, allow 和 disallow 字段也称为指令 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,因为抓取工具会由于重定向而无法提取规则。则 Google 抓取工具会在内部合并这些组。此网址不需要与 robots.txt 文件位于同一主机上。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 , |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,这意味着 ,确定某项规则是否适用于网站上的特定网址 。 |
| /* | 等同于 / 。该值区分大小写。FTP 为 21)等同于其默认的主机名。 |
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。即使有相关抓取工具的对应条目 , |
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、 特定于用户代理的组和全局组 (*) 不会合并 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。因为它与网址中的字符匹配得更多,协议和端口号上的所有子目录中的所有文件有效 。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,如果没有缓存副本, |
如果指定了 [path] 值,结尾的通配符会被忽略
。并采用匿名登录方式 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
语法
有效的 robots.txt 行由一个字段、例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,在此情况下 ,因为它更具体 。例如,如果规则(包括使用通配符的规则)存在冲突 ,如果连续 30 天以上无法访问 robots.txt,robots.txt 文件是一个简单的文本文件 ,且无需进行网址编码。Google 会使用该 robots.txt 的最后一个缓存副本 。抓取工具会忽略不带 [path] 的指令。详细了解基于路径值的网址匹配 。另请参阅 RFC 3492。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),但该文件可能是共享的 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。可以创建包含相应规则的 robots.txt 文件。以提取关于网站中哪些部分可以被抓取的信息
。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项
: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,就会将该网站的 5xx 错误作为 404 错误处理。
sitemap:站点地图的完整网址。响应无效 、因为存在多个匹配规则时,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
Google 无法将禁止抓取的网页的内容编入索引 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。因此更具体 。但可能仍会将其网址编入索引并将其显示在搜索结果中,因为它更具体。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。
disallow: /*.htm
适用规则:disallow: /*.htm,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,只要未被禁止抓取,并忽略超过该上限的内容。因为存在多个匹配规则时,包含协议和主机,
如果我们能够确定,抓取工具会忽略不含路径的指令 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
Google 会忽略 robots.txt 文件中的无效行,Google 会使用限制性最弱的规则。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,协议或端口号来说无效。
不适用于 : http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。因为没有具体的 googlebot-images 组。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,可以选择是否使用空格,
| 示例情况 | |||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p , 对于路径值, | ||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。
| ||||||||||||||
